メモリ不足というメッセージが出て強制終了されます | IllustStudioの要望・不具合ボード | CLIP STUDIO
よくある質問
教えて!Q&A
要望・不具合


IllustStudioの要望・不具合ボード

更新日:2012/08/06 09:01:16
反対数:0
賛成数:1
返信数:7
閲覧数:9321
ID:26162
from あやりんりん さん
2012/03/03 18:37:10
 
インストール/動作環境

メモリ不足というメッセージが出て強制終了されます

 

100以上という多量のレイヤーが原因とはわかっているのですが、
21MB B5同人誌表紙(B4:350dpi)程度のデータで50以下にレイヤーを減らしても
頻度は減りつつも、いったんエラーになった後はファイルが小さくなっても何度も強制終了されてしまいます。


 タスクマネージャ:メモリ(プライベートワーキングセット)が対象ファイル起動400,000k程度。

描画の場合は減ったり増えたりしていたメモリ数値が
レイヤーの結合等作業を進めるごとにメモリ数値が上がる一方で下がらず、とうとうメモリ不足のエラーメッセージが出て強制終了されてしまう、ということのくりかえしです。

(エラーはイラストスタジオのメッセージであったり、マイクロソフトのメッセージ「runtime errer」であったりまちまち)

仕方ないのでプロセス数値が1000,000kになったらいったんソフトを終了して再度ファイルを開いて作業をするしかない状態です。

改善策を教えてください。 


【現在の状況】

タスクマネージャープロセス

イラスタ起動のみ、ファイル未開封状態 41,452K
21MGファイル開封状態 248,180K
14個のレイヤーが入った圧縮ファイルを開いた状態 509,920K
(ファイルを閉じても248Kに戻らない)

上記フォルダを結合した状態 526,240K

クリッピングフォルダを含む23個のレイヤーが入った圧縮ファイルを開閉した状態 548,196K


上記フォルダ結合した際は一時的に600,000K位まで上昇後、233,220Kまで減少


17個のレイヤーが入ったフォルダ開閉状態 263,960K

未結合フォルダをいくつかのこした状態でjpg形式で書き出し後 842,760k


このまま減りません・・・・

 

 

現在イラスタ 900,000K
CPU使用率 6%
メモリ2.4GB

パフォーマンス
メモリ 4004MG
キャッシュ済 934MG
利用可能 1543MG
空きメモリ 610MG

賛成数:1   反対数:0   
from
CLIP
サポート担当
さん
2012/03/03 19:51:00
お客さまには、ご迷惑をお掛けし申し訳ございません。

IllustStudioで使用できるメモリーは、2GBまでになりますが、ご連絡いただいた数値を
確認すると、2GBには達しておらず、その状況で該当のメッセージが表示される場合は、
パソコン内のシステムキャッシュが溜まってしまい、多くのメモリーを消費している
可能性がございます。

一度パソコンをシャットダウンしていただいた後に起動していただき、改善されるか
お試しください。
(再起動では無く、一度シャットダウンをお願いします)

上記にて改善されない場合は、作品データに問題が発生している可能性もございますので、
「IllustStudio Ver1 設定」内の[BackupData]フォルダ内の作品ファイルでも同様かご確認を
お願いします。
※バックアップファイルの作成は、製品バージョンの1.2.0以降から追加された機能です。

バックアップファイルでも同様な場合は、該当のXPGファイルをデータ便にてこちらに送付を

お願いします。

データ便(株式会社データ復旧センター)

    ⇒宛先
        ・セルシスユーザーサポート
        ・tech@celsys.co.jp
      ※手続きの途中にて、メモという項目がありますので、そちらに
        「問い合わせ:
    http://www.clip-studio.com/clip_site/support/request/detail/svc/6/tid/26162
    と記載をお願いいたします。

なお、お送りいただいたデータは不出管理させていただき、データ検証など
完了次第、速やかにローカル及びサーバー上からも削除いたします。

お手数をお掛けしますが、よろしくお願いします。
......
from
スレ主
あやりんりん
さん
2012/06/30 18:53:47
全く新しいファイルでも同じ症状が出ます。
 
シャットダウンして再度ひいて同じ
 
B4サイズを半分にキャンパスサイズを変更しようとしたら完全にフリーズしたのでプロセスを見たら1,54,000k以上ありました・・・
 
タスクの終了もできなかったのでプロセスの終了をして、再度対象ファイルを開いて数値を確認したところ
134kでした。特定のフォルダを選択して移動したら712k、しかしそのフォルダを削除しても数値は下がりませんが
別のフォルダを結合したら数値は下がりました。
 
今回のファイルを送信します。
 
印刷所が高画質対応となり400Dpiにて作成したのもデータが大きくなってよくなかったのかもしれませんが・・・
 
こつこつフォルダを結合して保存していかないとメモリ不足にすぐエラーとなってしまいます。
from
CLIP
サポート担当
さん
2012/06/30 22:44:44
ご不便をお掛けしており申し訳ございません。

「ファイル」を送信していただいているということですが、まだこちらに
届いておりません。
ファイルサイズが大きい作品データをメールに添付してお送りいただいた場合、
プロバイダーの容量制限で送信エラーになってしまうことがございます。
そのため、前回ご案内しておりますデータ便にてお送りいただけないでしょうか。

上記の内容に合わせてご使用の環境についてもご連絡いただけないでしょうか。
・ご使用のOSについて
・ご使用のパソコンのCPUについて
 (パソコンの型番をお知らせ頂けましたらこちらでお調べいたします)
・HDDの空き容量について
・Illuststudioのインストール先について:

また、以下の操作でアプリケーションへの物理メモリの割り当てを変更して
改善するかお試しください。
[ファイル]メニューから[環境設定]→[メモリ]のアプリケーションの割り当て
を[自動に設定]から[割り当てサイズを指定]して物理メモリの割り当数を
大きくして改善するかお試しください。
from
愛瀬雅巳
さん
2012/08/05 12:57:49
少々古いスレッドに新規で質問を申し訳ありません。
IllustStudio
バージョン: 1.2.7
OS: Windows7-64bit(SP1)
CPU: Intel Corei7
Memory: 24GB
Video: RADEON  HD 6450 (1GB)
仮想HDD: AHA-9010 (exFAT形式・16GB中の2GBを使用指定)
 
の状態でも、レイヤーなどの数・画素数などに限らず、「メモリ不足で、指定のコマンドを実行することができません」というような内容のエラーが出て、最悪の場合そのウィンドウが凄い数開いて、動作を停止(Windowsから例外終了される)現象が起こります。
ちなみにこの現象は1.2.5等以前のバージョンでは起りませんでした。
 
何のコマンドで起るかわからず・新規起動・継続使用関わらず起ります。
ただラッキーな場合、例えばブラシなどで一点だけ書き加えてやったりすると、出なくなる場合がありますが、その後また起ったりします。
規則性は判らないのと、動作状態を外部から見ての、勝手な推測になるのですが……ヒストリやUNDOなど用の処理や、各種ファイルのインポート時などにメモリーリークなどが起っておりませんでしょうか?
 
また、もし、何か対処方法がございましたら、ご教示いただけますと助かります。
 
from
愛瀬雅巳
さん
2012/08/05 12:59:44
補足です。
上記の症状は、画面を拡大して・キャンバスを回転(画像の回転ではなく、ビューの回転)だけを行っているような場合でも、起ることがあります。
 
現象の報告に不足がありましたので、補足させていただきます。
from
愛瀬雅巳
さん
2012/08/05 13:03:37
何度も、すみません。投稿した後の症状で「起りやすいシチュエーション」を思い出したので、再補足です。
 
例えば、
「メインウィンドウ以外」にフォーカスがある(パレットウィンドウなど)時にキーボードショートカットを使用したり
素材ウィンドウから、素材を画像に貼り付けた後に
若干レスポンスが遅くなり・その後に起ることが多いかと(経験上)思われます。
 
from
CLIP
サポート担当
さん
2012/08/06 09:01:16
愛瀬雅巳さま

仮想HDD: AHA-9010 (exFAT形式・16GB中の2GBを使用指定)と、ご記載頂いておりますが
こちらはIllustStudioの環境設定の仮想メモリ作成先フォルダのことでしょうか。

お手数ですが、下記の手順をご確認下さい。

※下記にご案内する作業を行って頂きますとシルアルナンバーの再入力と
 インストールディスクの認証が必要になります。
 お手元にシリアルナンバーとIllustStudioのインストールディスクを
 ご用意頂き、作業を行って頂けますようお願いいたします。

以下にご案内する2つのフォルダをデスクトップに移動して頂いた上で
初期化起動をお試し下さい。

・[IllustStudio Ver1 設定]フォルダの場所について
C:\Users\(お客様のユーザー名)\Documents\IllustStudio Ver1 設定

【[IllustStudio Ver1 設定]フォルダを削除時に消去される項目】
[IllustStudio Ver1 設定]フォルダを削除されると、ペン等のツール設定や
お客様が作成されたマテリアル素材がクリアされ、これらがインストール
直後の状態に戻り、お客様が設定されたペン等のユーザー設定が消去されます。

・[Preference]フォルダの場所について
C:\ユーザー\(お客様のユーザー名)\AppData\Roaming\CELSYS\IllustStudio\IllustStudio\1.0

【[Preference]フォルダ削除時に消去される項目】
[Preference]フォルダを削除されると、環境設定の内容及びウィンドウ位置の
設定、シリアルナンバーの情報などが失われるため、[Preference]フォルダ
削除後の初回起動時には、シリアルナンバー認証が再度行われます。

[AppData]フォルダが表示されない場合は、[コントロールパネル]→[デスク
トップのカスタマイズ]→[フォルダオプション]を開き、[表示]タブの[詳細
設定]一覧の[ファイルとフォルダの表示]→[すべてのファイルとフォルダを
表示する]ラジオボタンを有効にしてから、[適用]ボタンをクリックします。

■初期化起動の方法
1.[Shift]キーを押しながら、デスクトップ上のIllustStudio 1.0の
  ショートカットまたはアプリケーション本体をダブルクリックします。
2.「初期設定をクリアして起動しますか?」が表示されるので、[はい]
  ボタンをクリックします。
3.[初期化起動]画面が表示されますので、[すべて選択]ボタンをクリックし、
  すべてのチェックボックスが有効になっているのを確認し、[OK]ボタンを
  クリックします。
4.IllustStudioMini 1.0が起動します。

今回デスクトップに移動を行ったフォルダを再度読み込む場合は、それぞれ
のフォルダを元の階層に上書きコピーを行って下さい。
なお、[Preference]フォルダや[IllustStudio Ver1 設定]フォルダに問題が
あり、今回の現象が発生している場合は、元に戻すことで再度問題が発生する
可能性があります。
その場合は、元の設定に戻すことはできませんので、改めてカスタマイズして下さい。

上記手順で改善がない場合は、ご使用のタブレットドライバを最新版に
アップデートして下さい。
以前のドライバをアンインストールの上、新しいドライバをインストールして
頂けますようお願いいたします。

また、セキュリティソフトをご使用の場合は、以下の3つのフォルダを除外設定
にして頂けますようお願いいたします。
セキュリティソフトの設定方法は、ご使用のセキュリティソフトウェアメーカー様へ
ご確認をお願いいたします。

C:\Program Files\CELSYS

C:\Users\(お客様のユーザー名)\Documents\IllustStudio Ver1 設定

C:\ユーザー\(お客様のユーザー名)\AppData\Roaming\CELSYS\IllustStudio\IllustStudio\1.0

以上、お手数ではございますが、ご確認頂けますようお願いいたします。

2019年11月28日に本サービスの投稿受付は終了いたしました。「CLIP STUDIO SUPPORT」をご利用ください。

よくある質問
教えて!Q&A
要望・不具合