「このコマンドを実行するのに十分な記憶域がありません」のメッセージ | IllustStudioの要望・不具合ボード | CLIP STUDIO
よくある質問
教えて!Q&A
要望・不具合


IllustStudioの要望・不具合ボード

更新日:2014/10/09 10:38:24
反対数:0
賛成数:0
返信数:6
閲覧数:41682
ID:30158
from azrin さん
2012/04/14 15:54:53
 
保存

「このコマンドを実行するのに十分な記憶域がありません」のメッセージ

 
幅  3576 px
高さ 4944 px
解像度 600 dpi
サイズ(ファイル容量) 118MB
のxpgファイルを保存しようとすると「このコマンドを実行するのに十分な記憶域がありません」のメッセージが出て保存できません。サイズが大きいのかと思い「キャンバス解像度の変更」で72dpiまで落としましたがやはり保存できませんでした。
さらに「キャンバス解像度の変更」でpxの数値を半分に設定しOKを押したのですが、今度はpxの値が変更できませんでした。
気になるのはこの操作をしたあと必ず同じ保存先のフォルダ内にTMPファイル(9MBくらい)が作成されていることです。これは正常に保存できていた時には作成されていませんでした。
いずれにしても、とても苦労してここまで描いてきた作品で、あともう少しで完成というところで保存ができなくなってしまったんです。
何とか保存して完成させたいので解決方法をお教えください。

---------------------------------------------------------
■IllustStudio
IllustStudio(   ) IllustStudioMini(〇)
バージョン:1.2.7
※[ヘルプ]メニュー→[バージョン情報]で確認できます。

■OS
Windows XP(   ) Windows Vista(   ) Windows 7(〇)
その他(   )
---------------------------------------------------------
賛成数:0   反対数:0   
from
CLIP
サポート担当
さん
2012/04/14 17:10:05
お知らせ頂きましたメッセージについてですが、ツールの操作時等に
メモリ領域を十分に確保できないために、この現象が発生している可能性が考えられます。

この現象を引き起こす原因としましては、以下の点が挙げられます。

・メモリを開放しないプログラムなどがバックグラウンドで常駐している場合、
  IllustStudioの動作に必要とするメモリが不足していることがあります。
・ドライブのシステムテンポラリフォルダに、不要なファイルが削除されずに
  残ってしまい、十分な空き容量が確保できていないことが考えられます。
 
■システムのテンポラリフォルダの場所について

  C:\Windows\Temp

■以下の手順で問題のあるツールセットを削除した上、ご使用頂けるかご確認ください。

1.[ペン]ツールを選択します。
2.[ツールセット]パレット左上のメニュー表示から[表示設定]→[テキスト]をクリックします。
3.[パターンブラシ]ツールを選択します。
4.[ツールセット]パレットで、ツールセット名が空白になっている物を探します。
5.空白になっているツールセットを削除します。
6.[ツールセット]パレット左上のメニュー表示から[表示設定]→[ストローク]をクリックします。

以上の操作によって改善するかご確認をお願いいたします。

もし空白のツールセットがない場合や、当該のツールセットの削除が
できない場合は、大変申し訳ありませんが現在の作品の保存を行うことが
非常に難しい状況となります。
その際は以下の方法をお試し頂けますようお願いいたします。。

■【重要】初期化起動の注意点について
[ツールセット]と[ツールスタイル]のチェックを有効にして初期化起動した
場合、設定がクリアされこれらがインストール直後の状態に戻ります。

この情報を保存される場合は[IllustStudio Ver1 設定]をデスクトップ
等にコピーします。

・[IllustStudio Ver1 設定]フォルダの場所について
  C:\ユーザー\(お客様のユーザー名)\ドキュメント

再度この情報を読み込む場合は、[IllustStudio Ver1 設定]フォルダを
元の階層に上書きコピーを行ってください。

なお、[IllustStudio Ver1 設定]フォルダに問題があり、今回の現象が発生
している場合は、元に戻すことで再度問題が発生する可能性があります。
その場合は、元の設定に戻すことは出来ませんので、改めてカスタマイズして
下さい。

■初期化起動の方法
1.IllustStudio 1.0が起動している場合は終了します。
2.[Shift]キーを押しながら、デスクトップ上のIllustStudio 1.0の
    ショートカットまたはアプリケーション本体をダブルクリックします。
3.メッセージダイアログ「初期設定をクリアして起動しますか?」が表示
    されるので、[はい]ボタンをクリックします。
4.[初期化起動]ダイアログが表示されますので、[ツールセット]と[ツール
    スタイル]のチェックボックスを有効にして[OK]ボタンをクリックします。
5.IllustStudio 1.0が起動します。

■IllustStudioのバックアップファイルについて
IllustStudio 1.2.0以降には上書き保存時のデータのバックアップを
行う機能がございます。

バックアップファイルはドキュメント内、[IllustStudio Ver1 設定]の
[BackupData]フォルダに保存されます。
念のため、ファイルが該当作品のファイルが格納されているかご確認を
お願いいたします。

■セキュリティソフトの設定について
上記の初期化起動でも改善しなかった場合は、セキュリティソフトのリアル
タイムスキャンなどの影響で問題が発生している可能性が考えられます。

お客様にはお手数ですが、ご使用のセキュリティソフトにてIllustStudio 1.0
や[IllustStudio Ver1 設定]フォルダを監視・制限している場合は、対象外に
設定していただき、問題が改善するかご確認ください。
from
スレ主
azrin
さん
2012/04/15 09:29:14
上記手順ですべてトライしましたが改善できませんでした。
ファイルをそちらにお送りするなどの方法でなんとか保存できる状態にしていただけませんでしょうか。
よろしくお願いします。
from
朧月夜に舞う胡蝶
さん
2012/04/15 14:49:05
azrin さまこんにちは。朧月夜に舞う胡蝶と申します。
横から失礼します。
 
絵をお描きになられたあと保存ができないとのことですが、
イラスタ独自形式 (xpg形式) ではなくフォトショ形式 (psd形式) での保存はお試しになられたでしょうか?
こちらでもイラスタ独自形式と同様に、レイヤを維持したままの保存が可能ですので
もしまだ試されていないようでしたらこちらで保存されてみてはいかがでしょう?
 
問題は「すでに試したがやはり保存できなかった」という場合ですが・・・
この場合はレイヤを維持したままでの保存は不可能となってしまいますが、
png形式での保存が可能でしたら以下のような方法でレイヤ別に保存することが可能です。
 
-----------------------------------------------------------------------------------------------
①レイヤパレット上から保存されたいレイヤのみを残してほかをすべて非表示にします。
 
②「ファイル」→「別名で保存」 (あるいは「指定の形式で保存」) でpng形式を選択します。
 
③「別名で保存」ダイアログが開きますから、この中から「設定を変更」ボタンを選択します。
 
④「PNG設定」ダイアログが開きますので、「表現色」を「RGBAカラー」に変更します。
 (最初はおそらく「RGBカラー」になっているかと思います)
 
⑤「OK」で同ダイアログを抜け、任意のファイル名をつけた後に「OK」で保存を行います。
 
⑥すべてのレイヤで①~⑤を繰り返せばレイヤごとに分割されて保存されますから、
 あとは次にイラスタを立ち上げた際にどれか1枚をまず「ファイル」→「開く」で開いたあとで
 同様に「ファイル」→「開く」でほかのファイルを開いて「矩形選択(矩形選択)」でキャンバス全体を範囲指定してから
 「編集」→「コピー」でコピーして最初に開いた画像のウィンドウで「編集」→「貼り付け」を行い、
 レイヤの位置関係を元と同じように並びかえれば元の状態に戻すことが可能です。
------------------------------------------------------------------------------------------------
 
ただ・・・この方法はレイヤの枚数が多くなると非常に保存や読み込みが面倒になることや
レイヤフォルダの情報を維持することができないなど何かと使いにくいことばかりですのであまりお勧めはできません。
イラスタ独自形式やフォトショ形式以外でレイヤを維持するためにはこの方法しかないわけですが・・・
 
それと万一png形式でも同様のメッセージが出て保存できなかった場合は
レイヤを維持することは不可能になってしまいますが・・・
スクリーンショットを使用するという方法で一応画像だけは保存することが可能です。
 
-------------------------------------------------------------------------------------------------
①「表示」→「ピクセル等倍」でお描きになられている絵を100%表示します。
 
この状態で絵がすべて表示された場合は②へ、
絵が大きすぎるなどの理由で一部しか表示されない場合は⑤へ進んでください。
 
②100%表示した状態で絵がすべて表示されるのでしたら
 その状態でプリントスクリーンキー (「Prt Sc」や「Prt Scr」などと書かれたキー) を押して
 スクリーンショットを取得します。
 
③MSペイントなどのソフトを立ち上げて「貼り付け」や「クリップボードから貼り付け」などを選択します。
 
④あとは絵が描かれた部分だけをトリミングすれば完了です。
 
*************************************************************************************************
 
⑤100%表示した際に絵がすべて表示されない場合は何度かに分けてスクリーンショットを取得することになります。
 基本的な方法は上記と同じですが、スクリーンショットは一度にひとつの画像しか扱えませんから、
 スクリーンショットを取得→MSペイントなどのソフトで貼り付けを行い保存→スクリーンショットを取得・・・を
 何度か繰り返すことになります。
 
⑥必要な部分すべてのスクリーンショットが取得でき、トリミングが完了したら
 イラスタを立ち上げ、元の絵と同じ大きさのキャンバスを新規作成してから
 「ファイル」→「開く」で⑤で保存したスクリーンショットの画像を開き、これを「矩形選択(矩形選択)」で
 キャンバス全体を覆うように範囲指定して「編集」→「コピー」でコピー、新規キャンバスに移ってから
 「編集」→「貼り付け」で貼りつけて「レイヤ移動(レイヤ移動)」ツールで所定の位置に移動させて
 png形式などで保存すれば完了です。
--------------------------------------------------------------------------------------------------
 
 
以上、取り留めのないことをだらだらと述べてきましたが、少しでも参考になれば幸いです。
それと乱文失礼いたしました。
from
CLIP
サポート担当
さん
2012/04/15 19:25:17
ご不便をおかけしており、申し訳ありません。

ご案内の項目についてすべてご確認いただいたとの事ですので、下記の内容を
お知らせいただけますでしょうか。

・問題のあるツールセットが存在し、それを削除されたという事でしたら、
 そのツールセットの名称と、同じツールのツールセットや、他のツールの
 ツールセットは問題ございませんでしたでしょうか。

・「このコマンドを実行するのに十分な記憶域がありません」のメッセージは
 保存をする際に出たメッセージで、各ツールを使用中には出ていません
 でしたでしょうか。

・ご使用のセキュリティソフトの名称をお知らせいただけますでしょうか。
 また、監視、制限の対象外の設定は可能でしたでしょうか。

・[ファイル]メニュー→[環境設定]にて表示される[環境設定]画面にて、
 左側のメニューから、[メモリ]を選択していただきますと、右側に、
 「仮想メモリの作成先フォルダ」等の記載が表示されますので、
 その状態で、[環境設定]画面を下記の方法にて、スクリーンショットを
 取得していただき、こちらへお送りください。

  ■スクリーンショットの取得手順

  1.キーボードの[PrintScreen]または[Prt Sc]とキートップに表示されて
    いるキーを押します。

  2.[Windows スタート]メニューをクリックし、[すべてのプログラム]の
    [アクセサリ]から[ペイント]を選択します。

  3.[ペイント]というアプリケーションが起動します。

  4.[編集]メニューから[貼り付け]を選択します。

  5.[PrintScreen]キーを押したときの画面のイメージが貼り付けられます。

  6.[ファイル]メニューから[上書き保存]を選択し、デスクトップなど適当な
    場所にファイルを保存します。
    ファイル形式はJPEGなどを選択してください。

・新規にキャンバスを作成し、適当に線を書いて保存した場合に、保存は
 出来ますでしょうか。

・現在の状態についてですが、編集が終わった状態で、保存のみができず、
 IllustStudioMiniは起動したままの状態でしょうか。
 そうではなく、既に保存ができない状態からIllustStudioMiniは終了されており、
 xpgファイルがエラーを出すなどして開けない状態になっているという事で
 しょうか。

・xpgファイルが開けないという場合は、IllustStudioMiniでバージョンが
 1.2.7をお使いとの事ですので、上書き保存をされたタイミングで、下記の
 場所にその際のバックアップデータが保存されるようになっております。

 C:\Users\(ユーザー名)\Documents\IllustStudio Ver1 設定\BackupData

 このため恐れ入りますが、こちらをご確認いただき、データがございましたら
 そちらを開いてご確認いただけますでしょうか。


よろしくお願いいたします。
from
iranm5196
さん
2014/10/09 00:34:21
コマンドを実行するのに十分な~のエラーが出た後はレイヤーを減らそうが、他のソフトを終了させようが
何をしても保存できません。
タスクマネージャでイラスタの使用メモリを確認しても300M以下の状態ですが、それでも保存できません。
メモリ等の環境の問題ではなく致命的なプログラムの欠陥ではありませんか?

購入時に、メモリを使いすぎると保存できなくなるという仕様についての説明が無く、また、エラーの発生する
条件についての説明や回避の方法についてもヘルプや説明書に記載はありませんでした。
悪質な欠陥商品の不良箇所を隠蔽して販売する詐欺行為ではないでしょうか?

またサポートの人間がOS付属のソフトであるアクセサリの使用によるスクリーンショットでの保存という、他社の製品
に依存した解決方法を提示するという事は、自社の製品の不全を認める行為ではないでしょうか?

確実に回避もしくは再発を予防する方法を提示できない限り、サポートを放棄した悪質な欠陥商品であると認識させていただきます。

・WIN XPsp3 ・ペンティアム4 3Ghz ・RAM 2G
from
CLIP
サポート担当
さん
2014/10/09 10:38:24
iranm5196 様

ご不便をおかけしており、申し訳ありません。

記載いただきましたメッセージにつきましては複数の可能性が考えられます
ので恐れ入りますが、以下の点をご確認頂けますでしょうか。

・IllustStudioを起動し、[ヘルプ]メニュー→[バージョン情報]を選択して
 [製品バージョン]をご確認ください。

 「1.2.7」以外の数値が表示されている場合は、お手元にシリアルナンバー
 (パッケージ版をご使用の場合はディスクも合わせて)ご用意の上、下記
 ページより最新バージョンのアップデータをダウンロードしていただき、
 インストールを行った上で再度ご確認をお願いいたします。

 ■IllustStudio アップデータ最新版


・最新バージョンへのアップデートを行っていただいた上で、メッセージが
 表示される場合は、以下の点をお知らせいただけますでしょうか。

 IllustStudioの[ファイル]メニュー→[環境設定]を選択すると表示される
 [環境設定]画面にて、左側のメニューから[メモリ]を選択した状態の
 スクリーンショットを掲載いただけますでしょうか。

 IllustStudioにてスクリーンショットを取得される場合はキーボードの
 [PrintScreen]または[Prt Sc]とキートップに表示されているキーを押して
 [ファイル]メニュー→[読み込み]→[クリップボードから新規作成]から
 行って頂ければと思います。


・新規に作品を作成していただき、そちらでも同様にメッセージが表示されるか
 ご確認の上、メッセージが表示されない場合は、作品データに問題が生じている
 可能性と作品ファイルのデータが、大きい為にメモリの使用上限を超えた処理が
 発生してしまい、メッセージが表示されている可能性がございます。

 ※32bitアプリケーションになりますのでIllustStudioにて使用できるメモリの
  上限は2GBまでとなります。

 作品データの破損の可能性につきましては、こちらでデータを確認させて
 いただければと思いますので、お手数ですが、以下のデータ便サービスで
 ファイルをアップロードしていただき、ファイルのダウンロード用のURLを
 お知らせください。

 ■データ便

 [ライトプラン]をご利用ください。
 100MBまでのデータを無料で送信することができます。

 1.[・データ便]が選ばれていることをご確認の上、[ファイルの選択]にファイルを
   ドラッグ&ドロップするとデータのアイコンが表示されます。
   同じ操作で複数のファイルを追加することもできます。
   有効期限、パスワード設定、ダウンロード通知はそのままでご利用ください。

 2.[利用規約に同意する]チェックボックスを有効にして[アップロード]ボタンを
   クリックすると、データのアップロードが開始されます。
   データの量、ネットワーク回線の状態によってお時間がかかることがありますが、
   アップロード中 はそのままお待ちください。

 3.「ファイルアップロード完了]メッセージが表示されたら[URL取得画面へ]ボタンを
   クリックします。

 4.「ダウンロードURL」欄にお客様がアップロードしたデータ専用のダウンロードURL
   が表示されますので、[COPY]ボタンをクリックして、以下の宛先までメールにて
   送信してください。
   [短縮URLの発行]から[作成]ボタンをクリックすると、短縮されてメールなどに貼り
   付けやすいアドレスに変換することもできます。

   宛先
   ・セルシスユーザーサポート
   ・tech@celsys.co.jp
   ・「問い合わせ:30158」と記載をお願いいたします。

   ※お送りいただいたデータは不出管理させていただき、データ検証など完了次第、
    速やかにローカル及びサーバー上からも削除いたします。


 また、レイヤーは増えれば増えるほどメモリーを消費してしまいます。
 すでに行われている操作かと思いますが、下記の操作を行っていただきますと消費を
 軽減でき、改善する可能性がございますのでお試しいただけますでしょうか。

 【編集の終わったレイヤーを統合/結合して、レイヤー数を減らしていただく。】

  レイヤーの統合、結合については[レイヤー]メニュー、[レイヤー]メニューの
  [メニュー表示]にございます。方法も用途によっていくつかございますので、
  下記内容をご参照ください。

  *レイヤーをすべて統合
   同じリブ内のすべてのレイヤーをひとつのレイヤーに統合します。

  *表示レイヤーを結合
   [レイヤー]パレットで編集中のレイヤーと同じリブに属している表示中の
   レイヤーだけを結合し、非表示のレイヤーはそのまま残します。

  *表示レイヤーのコピーを結合
    表示しているレイヤーのコピーを結合します。表示レイヤーもそのまま
    残ります。

  *選択中のレイヤーを結合
    選択したレイヤーをひとつのレイヤーに結合します。別々に描いた画像を
    ひとつに合わせる場合などに使用します。
    レイヤーを選択するときは、連続したレイヤーを選択する必要があります。

  *下のレイヤーに結合
   選択中のレイヤーとひとつ下にあるレイヤーを、ひとつのレイヤーに結合
   します。


 【圧縮フォルダを使用する】

  1.レイヤーフォルダを作成し、レイヤーをその中へ格納します。
  2.手順1で作成したレイヤーフォルダを選択します。
  3.[レイヤープロパティ]パレットで[フォルダ]タブを選択し、[圧縮フォルダ]に
    チェックを入れます。
  4.レイヤーを閉じます。

  なお、圧縮フォルダは[レイヤープロパティ]パレットの[フォルダ]タブにある
  [解像度と表現色を指定]をonにすると、解像度や表現色を設定できます。
  イラストの解像度が高い場合(200dpi以上)は、解像度を1/2以下に設定することで、
  また、[プレビューの表現色]で[グレー(16bit)]や[黒白(2bit)]に設定することでも、
  メインメモリの負担を軽減できます。
  どちらも、一時的に画像がグレーになったり、解像度が荒くなりますが、実際に
  記録されているレイヤーのデータが変更されることはありません。

よろしくお願いいたします。

2019年11月28日に本サービスの投稿受付は終了いたしました。「CLIP STUDIO SUPPORT」をご利用ください。

よくある質問
教えて!Q&A
要望・不具合