色を保持したまま白を透明に変換したい | CLIP STUDIO PAINTの要望・不具合ボード | CLIP STUDIO
よくある質問
教えて!Q&A
要望・不具合


CLIP STUDIO PAINTの要望・不具合ボード

更新日:2013/10/21 23:05:00
反対数:1
賛成数:2
返信数:9
閲覧数:102418
ID:69187
from noaon さん
2013/10/17 20:15:27
 
選択/編集

色を保持したまま白を透明に変換したい

 
クリスタには「輝度を透明度に変換」という機能(ツール?)がありますが、これをやるとカラーはモノクロのなってしまいますよね?
カラーはカラーのままで白を透明に変えたいのですが、そういった方法はありますか?なければそのような機能をつけて欲しいです。

------------------------------------------------------------
■バージョン:
※[ヘルプ]メニュー → [バージョン情報]で確認できます。

■グレード
DEBUT(   ) PRO(   ) EX( ○ )

■OS
Windows XP( ○ )  Windows Vista(   )
Windows 7 (   )  Windows 8(   )
MacOS X 10.5(   ) MacOS X 10.6(   )
MacOS X 10.7(   ) MacOS X 10.8(   ) その他(   )
------------------------------------------------------------
賛成数:2   反対数:1   
from
CLIP
サポート担当
さん
2013/10/18 09:53:00
白のみを透明に変更したい場合には、以下の手順にて行うことが
できますので、お試しください。

1.[レイヤー]パレットにて該当のカラーレイヤーを選択します。

2.[選択範囲]メニュー→[色域選択]をクリックします。

3.色域選択ダイアログが表示されましたら、選択タイプに
  [新規に選択]を選択し、[色の許容誤差]を調整後、
  キャンバス上の白で描画されている部分をクリックし、
  [OK]をクリックします。

4.白で描画されている部分に選択範囲が作成されたことを確認し、
  [編集]メニュー→[消去]をクリックします。

5.白部分が透明になることをご確認ください。

よろしくお願いいたします。
from
スレ主
noaon
さん
2013/10/20 13:32:13
説明が下手ですみません。少し違います。
「白の部分のみ」を消したいのではありません。
 
 
↑のようにしたいのではなく、
 
 
↑のようにしたいのです。
 
お分かりいただけますでしょうか?
from
CLIP
サポート担当
さん
2013/10/20 15:10:57
添付頂いた下部の画像は、同一レイヤー上で、白で塗りつぶされた上に
不透明度を変更したオレンジの描画が行われている状態でしょうか。

その場合、同一レイヤー上で、白の上にオレンジを塗り重ねておりますので、
塗り重ねる前の白色のみ消去することはできません。

前回ご案内した手順にて、オレンジ色以外の白色を透明にした後に、
レイヤーの不透明度を調整してください。

なお、白色の用紙レイヤーを作成すると、背景は白地になります。
その状態でしたら、[表示]メニューの[用紙]を選択することで、用紙レイヤーの
表示・非表示を切り替えることができます。
from
スレ主
noaon
さん
2013/10/20 16:34:35
すみません、丁寧な回答ありがとうございます。
 
私の要望は、「塗り重ねる前の白色のみ消去」する機能が欲しい、ということだと思います。
 
ネット上(pixivなど)にあるフリー素材で、透過されていないカラー素材があります。
その色、模様が複雑なものだと選択範囲で消すにも限界があります。
それをなんとかしたいのです。
 
 
例)
 
元画像
 
 
選択範囲で切り取った画像
 
 
 
私がしたい画像
 
 
(※全て私の自作画像です)
from
CLIP
サポート担当
さん
2013/10/20 18:40:14
Pixivなどのフリー素材とのことですが、画像ファイルの場合はレイヤーを統合
しますので、一枚のレイヤーに白い背景と塗りがある状態です。

同一レイヤーで塗り重ねておりますので、背景の白色のみ削除することは出来ません。

ご案内しております[色域選択]で白色を削除した後に、レイヤーの不透明度を
調整してご使用ください。
from
スレ主
noaon
さん
2013/10/20 23:16:57
つまり、今のクリスタではカラーのまま白を透明に変換できない、ということですね?
 
文で説明すると分かりにくいので画像で説明させていただきますが、
「輝度を透明度に変換」すると、
こうなります。
そして「[色域選択]で白色を削除した後に、レイヤーの不透明度を調整」すると
全ての色の透明度が同じになってしまいます。
しかし私は、彩度(明度)によって透明度も変えていただきたいのです。
↑このようにする機能を新たにつけていただきたい、という要望なのですが、お分かりいただけますでしょうか。
 
説明が下手で分かりにくくてすみません。 宜しくお願いいたします。
from
朧月夜に舞う胡蝶
さん
2013/10/21 15:51:32
noaonさまこんにちは。朧月夜に舞う胡蝶と申します。
横から失礼します。

色を保持したまま白を透明にされたいとのことですが、
現在のクリスタではそのような透過を行うことができないため、
代わりにAzPainter2の「フィルタ」→「アルファ操作」→「明るい色ほど透明に」を
使われてはいかがでしょう?
(AzPainter2はフリーソフトのため無料です)

------------------------------------------
1.AzPainter2を立ち上げ、余白を透過したいファイルを開きます。

2.「フィルタ」→「アルファ操作」→「明るい色ほど透明に」を使用します。

3.このままでは薄いので何枚かレイヤをコピーします。
 (およそ5~6枚重ねることで元の不透明度と同じになります)

4.あとは全てのレイヤを結合すれば完了です。
 (レイヤウィンドウ(レイヤパレット)の「レイヤ」から
 「表示レイヤをすべて「通常」結合(α維持)」を使用することで
 余白が透明なままの全結合が可能です)

------------------------------------------
元画像です
(イラスタで雲模様を使用したあとグラデ彩色で自作の「宝石グラデ(金紅石)」を使用して着色しました)






AzPainter2で透過したものです。
(分かりやすいように左半分だけ白背景を入れてあります。
それと右半分のピンクのチェック模様の部分が透明であることを表しています)





以上、取り留めのないことをだらだらと述べてきましたが、
少しでも参考になりましたら幸いです。
それと乱文失礼いたしました。
from
CLIP
サポート担当
さん
2013/10/21 19:43:38
noaon さま

お客様のご指摘の通り、色域選択で白を透明にした後に、レイヤーの
不透明度の変更を行うと、すべての色の透明度が変更します。

彩度や明度に合わせて透明度を変更できる機能につきましては、
現象ありませんので、今後の製品開発にて対応を検討して参ります。


朧月夜に舞う胡蝶 さま

 アドバイスいただきありがとうございます。
from
スレ主
noaon
さん
2013/10/21 23:05:00
朧月夜に舞う胡蝶様

アドバイスありがとうございます!「明るい色ほど透明に」は、まさに私が求めていた機能です!
他のソフトを使うという手があったんですね、目から鱗でした。
早速ダウンロードして使ってみようと思います。
 
サポート担当様
 
長々と下手な説明で申し訳ありませんでした。
今後CLIP STUDIO PAINTにもAzPainter2の「明るい色ほど透明に」のような機能が搭載されることを願っています。
ありがとうございました。
コメントの投稿にはログインが必要です。
よくある質問
教えて!Q&A
要望・不具合