CLIP STUDIO PAINT PROで線画抽出したいのですが… | CLIP STUDIO PAINTの要望・不具合ボード | CLIP STUDIO
よくある質問
教えて!Q&A
要望・不具合


CLIP STUDIO PAINTの要望・不具合ボード

更新日:2016/07/06 03:42:15
反対数:0
賛成数:0
返信数:6
閲覧数:60561
ID:87344
from 柚チャン さん
2016/07/05 20:07:41
 
3D

CLIP STUDIO PAINT PROで線画抽出したいのですが…

 
ダウンロードした3D素材をLT変換したり線画抽出したりしたいんですがPROではどうやればいいんですか?

------------------------------------------------------------
■バージョン:
※Windowsは、[ヘルプ]メニュー → [バージョン情報]で確認できます。
※MacOSXは、[CLIP STUDIO PAINT]メニュー → [バージョン情報]で確認できます。

■グレード
DEBUT(   ) comico(   ) PRO(  ○ ) EX(   )

■OS
Windows XP(   ) Windows Vista(   ) Windows 7 (  ○ )
Windows 8(   ) Windows 8.1(   ) Windows 10(   )
MacOS X 10.5(   ) MacOS X 10.6(   ) MacOS X 10.7(   )
MacOS X 10.8(   ) MacOS X 10.9(   ) MacOS X 10.10(   )
MacOS X 10.11(   ) その他(   )
------------------------------------------------------------
賛成数:0   反対数:0   
from
CLIP
サポート担当
さん
2016/07/05 20:31:52
恐れ入りますが、CLIP STUDIO PAINT PROにLT変換機能は搭載されておりません。

LT変換機能を使用されたい場合はCLIP STUDIO PAINT EXをご購入ください。

グレードによる機能の違いは、以下のページをご参照ください。

CLIP STUDIO PAINT 機能一覧

よろしくお願いいたします。
from
スレ主
柚チャン
さん
2016/07/05 22:15:03
質問が分かりにくくてすみません
PROではそういった機能が搭載されて無いってことは知っています

ただLT変換に替わる別の方法などで似たことが出来るのかが知りたかったんです(例えばレイヤータブの○○を使えば線画抽出が出来る等)
from
朧月夜に舞う胡蝶
さん
2016/07/06 00:43:55
柚チャンさま>
残念ながらクリスタにはAzPainter2(無料)やGIMP(無料)、フォトショのような
輪郭抽出フィルタが存在しませんので
Pro版でLT変換のようなことを行うのは難しいかと思います。

ただ、逆に言えば上記のようなソフトを使うことで
輪郭を抽出できますから、pngなどの形で保存して
クリスタ以外のソフトで輪郭抽出してみてはいかがでしょう?

以下は実際に各ソフトで輪郭抽出してみた例です。
【原型】



【AzPainter2】
「フィルタ」→「輪郭抽出」→「Laplacian」で輪郭抽出したあと
「フィルタ」→「カラー」→「レベル補正」で「入力中間」を200に設定、
さらに「フィルタ」→「カラー」→「2値化」で閾値を200にして二値化してみました。



二値化していますので当然ながらアンチエイリアスが消滅しています。
そのため必要なら「フィルタ」→「アンチエイリアシング」を適当な強度で使用して
アンチエイリアスを復活してあげてください。
(以下の例では強度210でアンチエイリアシングしています)



【GIMP】
「フィルタ」→「輪郭抽出」→「ガウス差分」(数値はそのまま変更なし)で輪郭抽出したあと
「色」→「レベル」で「入力レベル」の中間値を0.25にしてみました。



from
けも
さん
2016/07/06 02:39:12
朧月夜に舞う胡蝶さまの画像をお借りします

画像を複製します
複製したレイヤーの合成モードを「紗の絶対値」にします
そのままそのレイヤーを右と下に2pxずつ移動させます(左と上でもよいです 2pxでなくてもよいです)
黒い画面に線が出ますので
メニューのレイヤーから「色調補正レイヤー」の「諧調の反転」を選びます
↓こんな感じになります


このあとはお好きに
from
けも
さん
2016/07/06 03:16:25
もうひとつ

画像を3枚複製します(何枚にするかは自分で判断します)
それぞれの画像を40、100,180で2値化します(数値は絵を見ながら輪郭が欲しいところで判断します)
レイヤーを一枚ずつ「レイヤーの変換」をしていきます
メニューのレイヤーから「レイヤーの変換」を選びます
種類をベクターレイヤーに
表現色をグレーに
「ベクターの設定」をクリックして
最大線幅を1とか2とか3に(それ以外でも可)
補正は1を
他は2値化されているのでかんけいないです
「OK」してください

↓3枚とも変換した物がこちら


ベクターのいらない線を消すなりしてください
from
けも
さん
2016/07/06 03:42:15
すみません「紗の絶対値」になってました「差の絶対値」ですね
差の絶対値は位置合わせなどに使う時に便利です

レイヤーの変換はラスターのラインをベクターにするのですが
CLIP STUDIO PAINTでは塗りつぶしが変換できず
輪郭の変換になってしまいます
それを利用してみました

2値化の数値を変えるやりかたは
手作業のLT変換です
これもいろいろと使えると思います
今回はライン抽出に利用できるかもと思いやってみました

汚してすみません

2019年11月28日に本サービスの投稿受付は終了いたしました。「CLIP STUDIO SUPPORT」をご利用ください。

よくある質問
教えて!Q&A
要望・不具合