clip形式のファイル容量について | CLIP STUDIO PAINTの要望・不具合ボード | CLIP STUDIO
よくある質問
教えて!Q&A
要望・不具合


CLIP STUDIO PAINTの要望・不具合ボード

更新日:2016/03/25 19:03:55
反対数:0
賛成数:39
返信数:10
閲覧数:10756
ID:85097
from WinOPZ さん
2016/03/21 16:47:24
 
保存/印刷

clip形式のファイル容量について

 
clip形式のファイル容量ですが、特定の操作を行うとファイル容量が減ります。

1.「キャンバスサイズを変更」を選ぶ
2.サイズ値を変更せずにOKを押す
3.上書き保存

この操作によってファイル容量が変化します。

この仕様は一体どういうことでしょうか?

Ver.1.5よりlip形式からclip形式へ変更があり、最適化保存がなくなりました。
しかしまだ何か無駄な情報が、ファイルに残ってしまっているのではないでしょうか?


まずユーザーとしては、

・この減った分の情報が一体どのようなものなのか?
・なくなっても問題ないのか?

分かりません。

また不要であるならば、今後残さず保存できるような改善をお願いします。

ご確認よろしくお願いします。

------------------------------------------------------------
■バージョン:Ver.1.5.3
※Windowsは、[ヘルプ]メニュー → [バージョン情報]で確認できます。
※MacOSXは、[CLIP STUDIO PAINT]メニュー → [バージョン情報]で確認できます。

■グレード
DEBUT(   ) comico(   ) PRO(   ) EX( ◯ )

■OS
Windows XP(   ) Windows Vista(   ) Windows 7 (   )
Windows 8(   ) Windows 8.1(   ) Windows 10( ◯ )
MacOS X 10.5(   ) MacOS X 10.6(   ) MacOS X 10.7(   )
MacOS X 10.8(   ) MacOS X 10.9(   ) MacOS X 10.10(   )
MacOS X 10.11(   ) その他(   )
------------------------------------------------------------
賛成数:39   反対数:0   
from
CLIP
サポート担当
さん
2016/03/21 19:38:20
ご連絡を頂きありがとうございます。

以下の点についてお知らせいただけますでしょうか。

・ファイル容量が減ると頂きましたが、おおよそどの程度減りました
 でしょうか。また、キャンバスサイズと解像度はおいくつでしょうか。

・手順の1~3を行われた際に開かれていたclipファイルについては
 編集中のデータでしょうか。
 また、バージョンいくつで作成されたものでしょうか。

・[ファイル]メニュー→[新規]にて[作品の用途]で[イラスト]を
 選択し、プリセットで[800×600(72dpi)]を選択して、適当に
 描画して、デスクトップに保存後、手順の1~3を行われた際に
 同様に容量が減る状態かご確認をお願いいたします。

 また保存後ファイルを開き直して手順の1~3を行われた際に
 同様に容量が減る状態かご確認をお願いいたします。

お手数ですが、よろしくお願いいたします。
from
スレ主
WinOPZ
さん
2016/03/21 20:11:11
データ1:1500x1500px 350dpi
元:15.7MB
後:13.8MB
データ2:2034x1500px 350dpi
元:5.58MB
後:5.46MB
データ3:3500x3500px 350dpi
元:21.6MB
後:11.4MB
データ4:3750x3750px 350dpi
元:37.3MB
後:26.5MB
データ5:2513x3541px 350dpi
元:53.2MB
後:36.8MB

データは編集中、編集終了済みのデータ関係なく減少します。
減少量はファイルによって違い、規則性は無いように思います。

データ1~4はVer.1.5.3、データ5に関してはVer.1.5.0作成の物と思います。
from
スレ主
WinOPZ
さん
2016/03/21 20:35:20
800x600 72dpiでファイル作成し、少し描画した程度のファイルでは「キャンバスサイズの変更」を行ってもファイルサイズは小さくなりませんでした。
むしろ少し増えました。

色々試した結果、下記の手順を行った際にファイルサイズが小さくなりました。

1. 800x600 72dpiでファイル作成
2. 初期設置されたレイヤーを塗りつぶす。
3. 「拡大縮小回転」で縦横50%縮小
4. 新規ラスターレイヤーを作成して、手順2、3を行う。
5. 用紙レイヤーを除きラスターレイヤーが5枚になるまで行う。
6. 作成された5枚のラスターレイヤーをフォルダーに入れ、デスクトップにtest3.clipとして保存。
7. 「キャンバスサイズを変更」を選ぶ
8. サイズ値を変更せずにOKを押す
9. 上書き保存

この手順を行った結果

手順6でのサイズ:251KB
手順9後のサイズ:250KB

と変化しました。

このことから、ある程度編集したデータで何か起こるものと考えられます。
また手順9を上書き保存にしても、別名保存にしてもファイル容量は同じでした。
from
スレ主
WinOPZ
さん
2016/03/21 20:57:48
次に行った事を記述します。

1. 800x600 72dpiでファイル作成
2. 初期配置されたレイヤーをフォルダに挿入
3. test7.clipとして保存

この時点でのtest7.clipは「146KB」

4. 開かれた状態のレイヤーフォルダを閉じて、上書き保存

この時点でのtest7.clipは「156KB」
容量増加。

5. もう一度レイヤーフォルダを開いて、上書き保存

この時点でのtest7.clipは「156KB」
変化なし。

6. 「キャンバスサイズを変更」を選び変更せずにOK。
7. 上書き保存

この時点でのtest7.clipは「155KB」
減少しました。


レイヤーフォルダの処理に何かあるのではないかと感じました。
from
摩耶薫子
さん
2016/03/21 21:13:32
失礼いたします。
私も少し検証してみました。

同様の手順で、

データ1:5181px*3623px 350dpi バージョン1.5.3
元:84.2MB
後:39.2MB

データ2:4441px*6213px 600dpi
元:バージョン1.4.* .lipファイル時点 56.7MB
1.5.3で.culp形式に別名保存時点 33.1MB
後:21.9MB

一旦「キャンバスサイズの変更」の後保存してサイズダウンしたファイルは、その後何も作業をせずにもう一度同様に「キャンバスサイズの変更」をして保存してもファイルサイズは変わりませんでした。

また、サポート担当の方の返信にありましたとおり、ファイル新規作成で実行してみましたが、多少作業をした程度では、容量はむしろ多少ですが増加しました。
417KB→443KB
708KB→750KB
926KB→955KB

フォルダー格納や、フォルダー内のレイヤーに描画もしてみましたが、やはりあまり作業をしていない状態のファイルですと、サイズは多少増加するようです。

from
聖月
さん
2016/03/21 21:58:31
私の環境でも同様の現象が起きます。

元lipから引き継いだデータですが、clipファイルにして何度か上書きしています。
複数ページで作業しています。
8598px×6071px 600dpi
115MB→93MB

新規で追加した白紙ページ
同用紙サイズ解像度
563KB→584KB

先のお二方と同じである程度描き込みのあるデータは容量が減りましたが、白紙ページは増えました。
容量が大きいファイルは減り幅も大きく、容量が低めのファイルは減り幅は少ないようです。
白紙や描き込み量が少ないと逆に容量が増えるという現象がおきます。
from
ぶひぃ
さん
2016/03/21 23:47:01
失礼いたします。私も同じ現象が起きました。参考がてら書かせていただきます。

●win7、ver1.5.3、EX、検証データはすべて編集終了

【データ1】 イラスト
ver1.5.3で制作 4093 × 2894 px 350dpi
55.9MB → 42.6MB
【データ2】 複数ページ 漫画
ver1.4.3、lipで制作、clipで別名保存 6071 × 8598 px 600dpi
763 MB(lip) → 330MB → 268MB
【データ3】 イラスト
ver1.5.3で制作 4961 × 7016 px 600dpi
275MB → 189MB
【データ4】イラスト
ver1.4.1、lipで制作後、clipで別名保存 2894 × 4093 px 350dpi
270 MB(lip) → 98.3 MB → 84.7 MB

・[ファイル]メニュー→[新規]にて[作品の用途]で[イラスト]を
 選択し、プリセットで[800×600(72dpi)]を選択して、適当に
 描画して、デスクトップに保存後、手順の1~3を行う

こちらはサイズが増えました。1.14 MB → 1.47 MB
from
tangerine3
さん
2016/03/22 02:01:01
失礼いたします。私も同様の現象を確認しましたので、ご報告いたします。<Win7使用 >

【データ1】 単ページ 漫画 4961 × 7016 px 600dpi
ver1.4.2でlip保存→ver1.5.0使用でclip別名保存→「キャンバスサイズの変更」後に上書き保存
106MB(lip) → 52MB → 28MB  (レイヤー数32 レイヤーマスク・定規多用)

【データ2】モノクロイラスト 6988 × 4998 px 600dpi
ver1.4.2でlip保存→ver1.5.0使用でclip別名保存→「キャンバスサイズの変更」後に上書き保存
75MB(lip) → 37MB → 6MB   (レイヤー数12 レイヤーマスク多用)
※6MB以後2回ほどキャンバス変更を行ったがサイズに変化なし

・詳しいサイズは覚えていませんが、
 ver1.5.0で新規作成からclipで保存しても、長時間かけて描いたイラストは 80MB → 20MB と格段に減りました。
 
--------------------------- 
【データ3】 イラスト(検証) 800 × 600 px 72dpi
ver1.5.0で新規作成・描画後clip保存→キャンバスサイズの変更で
355KB → 415KB   (レイヤー数4 レイヤーマスクなし)
※以後2回ほど、キャンバス変更を行ったがサイズに変化なし

【データ4】イラスト(検証) 1378 × 2039 px 350dpi
ver1.5.0で新規作成・描画後clip保存→キャンバスサイズの変更で
19,506KB → 21,479KB   (レイヤー数40 レイヤーマスク多用)
※以後2回ほど、キャンバス変更を行ったがサイズに変化なし

【データ5】漫画(検証) 6071 × 8598 px 600dpi
ver1.5.0で新規作成・描画後clip保存→キャンバスサイズの変更で
2,787KB → 3,255KB   (レイヤー数10 レイヤーマスクなし)
※以後2回ほど、キャンバス変更を行ったがサイズに変化なし

データ3~5は、新規作成して描画(レイヤー追加)で保存後、キャンバス変更して保存したものと比べると、ファイル容量は増えました。(みなさまと同様です)
しかし、3~5を続けて検証したところ、
レイヤー(描画あり)を増やしたり減らしたりしてから、キャンバス変更を行うと、ファイル容量は減少(変動)しました。
以下、詳細を記します。
 
【データ3続き】
レイヤー削除→キャンバス変更 297KB → 294KB    (- 3KB)
レイヤー追加→キャンバス変更 362KB → 360KB    (- 2KB)
レイヤー追加→キャンバス変更 3,807KB → 3,774KB (- 33KB)
レイヤー追加→キャンバス変更 6,818KB → 6,896KB (+ 78KB)
レイヤー追加→キャンバス変更 9,942KB → 10,105KB (+ 163KB)
レイヤー削除→キャンバス変更 7,040KB → 6,974KB (- 66KB)
レイヤー削除→キャンバス変更 3,964KB → 3,931KB (- 33KB)
レイヤー削除→キャンバス変更 1,183KB → 1,181KB (- 2KB)
レイヤー削除→キャンバス変更 1,062KB → 1,062KB (変化なし)
レイヤー追加→キャンバス変更 3,735KB → 3,711KB (- 24KB)
レイヤー追加→キャンバス変更 6,673KB → 6,673KB (変化なし)
レイヤー削除→キャンバス変更 3,735KB → 3,711KB (- 24KB)

あるファイルは、10回以上こういう操作を続けていくと、途中からサイズ変化が起こらなくなったものもありました。
(レイヤー増減→キャンバス変更しても5回以上容量に変化なし)

参考になればと思い、細々と失礼しました。この現象の解決と改善を強く希望いたします。
from
デェタ
さん
2016/03/22 02:23:07
失礼いたします。
上にコメントされているみなさまと同様の現象が起きているため参考までに記入させていただきます。

すでに同様の報告が多数上がっておりますため詳細なファイルの内容については割愛させていただきますが、
傾向としては、ほとんど作業をしていない比較的小さなファイルサイズ(1MB~10MB程度)のものについては
「キャンバスサイズの変更→保存」処理後にファイルサイズが微増し、
10~20MB以上のサイズのファイルになると処理後にファイルサイズが減る(大きなサイズのファイルほど
大きく減る)という傾向が見られました。
環境はWindows7 Professional、EX Ver1.5.1です。


また、これまでに報告のない点で一点、
「キャンバスサイズの変更」コマンドを実行後、アンドゥ(Ctrl+z)を行ってから保存をしても
同様にファイルサイズが変化する現象を複数のclipファイルにて確認しております。

参考までに変化の一例を添付いたしますのであわせてご参照ください。



「page0004.clip」 →「キャンバスサイズの変更」処理前のファイル
「page0004 - コピー.clip」 →「キャンバスサイズの変更」処理後、そのまま保存したファイル
「page0004 - コピー(2).clip」 →「キャンバスサイズの変更」処理後、アンドゥしてから保存したファイル


ひとまず報告は以上です。
併せてご検証の一助となりましたら幸いです。
どうぞよろしくお願いいたします。
from
CLIP
サポート担当
さん
2016/03/25 19:03:55
お時間を頂いており、申し訳ありません。

保存されているclipファイルにつきましては表示、編集の高速化の
ためのフォルダーやキャンバスの合成結果のキャッシュが、
含まれております。

キャンバスサイズ変更、画像解像度の変更を行いますと、
このキャッシュが破棄されますのでサイズが変化いたします。

キャッシュは破棄されても処理上、必要なときに再作成されますので、
問題ございませんが、処理前に再作成の時間が必要となる為、
その分、処理の完了までに時間を要する可能性がございます。

キャッシュデータの保存は、作業中の表示速度向上とメモリ節約の
ためにしている動作ですが、ファイル容量の削減を優先されたい
という事もあるかと思いますので、キャッシュデータを削除して保存する
選択肢を設けるなど、対応策を検討してまいります。

よろしくお願いいたします。

2019年11月28日に本サービスの投稿受付は終了いたしました。「CLIP STUDIO SUPPORT」をご利用ください。

よくある質問
教えて!Q&A
要望・不具合