読み込んだ画像の透過 | CLIP STUDIO PAINTのみんなに聞いてみよう | CLIP STUDIO

CLIP STUDIO PAINTのみんなに聞いてみよう

質問&回答しよう!

クリエイターさん同士で、教えて教わる相談コミュニティ

質問を見てみる
更新日:2015/02/25 14:12:15
返信数:2
閲覧数:89897
ID:77456
from 七摘 さん
2015/02/24 20:48:44
 
選択/編集

読み込んだ画像の透過

 
イラレで作成してJPEGで保存されたロゴを読み込んでイラストに貼り付けたいのですが、ロゴの周りに白い部分があるので透過させたいです。

元々透過されてないものなのですが、読み込んだ後に透過させることはできるのでしょうか。



------------------------------------------------------------
■バージョン:
※[ヘルプ]メニュー → [バージョン情報]で確認できます。

■グレード
DEBUT(   ) PRO(  ○ ) EX(   )

■OS
Windows XP(   ) Windows Vista(   ) Windows 7 (   )
Windows 8( ○  ) Windows 8.1(   )
MacOS X 10.5(   ) MacOS X 10.6(   ) MacOS X 10.7(   )
MacOS X 10.8(   ) MacOS X 10.9(   ) MacOS X 10.10(   )
その他(   )
------------------------------------------------------------
from
えみあ
さん
2015/02/25 08:07:51

こちらのアクションをCLIP STUDIOからダウンロードしてお使いください。
既存画像の不要な部分を自動選択などで選択しアクションを再生すれば不要な部分が透明になります。
背景が透明でない画像の背景などを透過するために作ったアクションです。
from
朧月夜に舞う胡蝶
さん
2015/02/25 14:12:15
七摘さまこんにちは。朧月夜に舞う胡蝶と申します。
横から失礼します。

jpeg画像の余白を透過したいとのことですが、
クリスタには「輝度を透明度に変換」という機能がありますので
こちらを使われてみてはいかがでしょう?

----------------------------------------------
1.まずクリスタを立ち上げ、「ファイル」→「開く」で
 余白を透過したいjpeg画像を開きます。
 (以降の説明もすべて同じですので以下省略します)

2.次に「編集」→「輝度を透明度に変換」をクリックします。

----------------------------------------------
以上です(笑)
ただ…上記の方法は黒1色の線画を透過するにはいいんですが、
フルカラーのものに対しては白黒(正確には灰色の濃淡ですが)になってしまうためお勧めできません。

そのためフルカラーのものを(フルカラーのまま)透過したい場合は
別の方法で透過する必要があります。

・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・
【フルカラーでの余白透過方法その1】
方法その1はマジックワンドを使用する方法です。

1.「自動選択(編集レイヤのみ参照)」ツールを使用して
 余白(透過したい部分)をクリックします。
 (「選択範囲」→「色域選択」でも同じことができますので七摘さまのお好きなほうでどうぞ)
 
2.範囲指定できたら透明色を選択してから選択範囲ランチャの「塗りつぶし」や
 「塗りつぶし(編集レイヤのみ参照)」ツールなどを使用して塗りつぶしを行います。

以上です。
それと、透明色で塗りつぶした結果、イラストの周囲に白残りする部分が発生した場合は
一度アンドゥでやり直してもう一度範囲指定したあと
「選択範囲」→「選択範囲を拡張」で1~2pxほど拡張してから塗りつぶしてみてください。

***

【フルカラーでの余白透過方法その2】
その2は範囲指定用の新規レイヤ(ラスタレイヤ)を作成して
トレス→マジックワンドなどで範囲指定して周囲の余白を除去する方法です。
こちらについては長くなりますので、「背景素材をイラストにかぶらないようにする方法」での
わたしの書き込みの「【2】範囲指定用のベタ塗りレイヤを作成する場合」をご覧ください。

***

【フルカラーでの余白透過方法その3】
その3はAzPainter2(無料)のフィルタ「明るい色ほど透明に」を使用する方法です。

1.まずAzPainter2を立ち上げ、「ファイル」→「開く」で
 余白を透過したいファイルを開きます。

2.次に「フィルタ」→「アルファ操作」→「明るい色ほど透明に」をクリックします。

3.(2)ですでに余白は透過されていますが、そのままでは薄いので
 レイヤパレットの「レイヤ」から「複製」をクリックして何枚かレイヤを複製します。

4.あとは「ファイル」→「別名で保存」で「ファイルの種類」をpngにして「保存」をクリック、
 次に表示される「png保存」ダイアログから「アルファ付き32bitカラー」を選択して
 「OK」すれば完了です。

・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・‥…━…‥・

それとイラレで作成された画像ファイルとのことですので
もしイラレが使えるようでしたらイラレで元ファイル(aiやepsなどのファイル)を開いて
「ファイル」→「書き出し」でファイルの種類をpngにして「保存」をクリックしたあと、
次に表示される「pngオプション」ダイアログから「背景色」を「透明」にすることで
アルファ付きpng(余白透過png)で書き出すことが可能ですから
そちらを使われたほうが余白透過の手間がなく楽ですし確実かと思います。


以上、取り留めのないことをだらだらと述べてきましたが、
少しでも参考になりましたら幸いです。
長文&乱文失礼いたしました。